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La puissance du dessin  
vectoriel sous Linux

Xara Xtreme pour Linux
André Pascual

Version libre pour Linux du puissant logiciel de dessin vectoriel 2D de la société 

Xara, Xara Xtreme pour Linux, abrégé en XaraLX, a des capacités comparables 

à CorelDraw ou Illustrator. Certes moins connu du grand public que le logiciel 

libre Inkscape, sa puissance et sa rapidité d’exécution en font un outil parfaitement 

adapté aux besoins des professionnels du graphisme travaillant sous Linux.

Au travers d’exercices abondamment illustrés, cet ouvrage permet la prise en 

main et la maîtrise progressive des fonctionnalités du logiciel, afin de réaliser des 

illustrations vectorielles en toute autonomie. 

Malgré de légères variantes, ce manuel très didactique pourra tout aussi bien 

s’adresser aux utilisateurs de Xara Xtreme sous Mac OS X ou Windows.



4À vos souris ! 
Première partie
Après le tour du propriétaire, informatif, vient l’usage des lieux
visités ; autrement dit, après la théorie, vient la mise en
pratique... Alors, à vos souris !

B alignement horizontal et disposition verticale
B calque
B clonage
B copie d’attributs
B dessin au crayon
B logotype
B mise en couleur
B modèle de couleur
B outil Biseau (Bevel)
B outil Fusion (Blend)
B texte
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Il y a plusieurs façons d’envisager l’apprentissage d’un logiciel :
• à partir d’un unique exercice guidé, dont la complexité de réalisation nécessite l’emploi

de la totalité des fonctions disponibles ;
• à partir de plusieurs exercices brefs, de difficulté croissante ou non, qui recourent cha-

cun à un nombre limité de fonctions.

C’est la deuxième solution qui a été choisie. Il semble en effet plus facile de retrouver une
information isolée dans une structure parcellisée que fondue au sein d’un ensemble
unique, trop fourni en données.

En conséquence, quelques exercices pas-à-pas sont proposés, à réaliser souris en main.
Chacun devrait permettre d’apprendre un aspect des possibilités de XaraLX. Les fonc-
tionnalités détaillées dans un exercice ne le sont plus dans l’exercice suivant : leur méca-
nisme est supposé être acquis dès lors qu’il a été explicité une fois.

Un logotype simple (et plus si affinités...)
Il y a plusieurs années déjà, j’ai été chargé de la conception du logo de Scideralle, associa-
tion de soutien et de promotion des projets visant à fournir à tout public des logiciels et
ressources libres pour l’éducation au sens large. À cette époque, l’offre vectorielle sous
Linux était limitée, et j’avais acquis une certaine pratique de Sketch, devenu Skencil par
la suite ; c’est donc avec cet outil que j’ai dessiné le logo, représenté sur la figure 4-1. Nous
allons ici apprendre à le créer avec XaraLX.

Un examen rapide du logotype nous indique qu’il est composé de trois éléments distincts :
• un dessin, le goéland ;
• un second dessin, le ciel bleu bicolore ;
• un texte, le logo proprement dit, avec une fantaisie : une étoile à la place du point sur

le « i ».
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COMPRENDRE   Logotype

Un logotype, ou simplement logo, désigne le nom d’une entreprise, d’une associa-
tion ou d’une institution. Il est élaboré à l’aide d’une police de caractères particu-
lière, souvent créée pour l’occasion, et le texte est disposé d’une manière parfois non
conventionnelle, mais il doit toujours être lisible. Le nom et le lettrage doivent être
uniques afin de permettre l’identification immédiate de l’entité que le logo
représente : Coca-Cola, Sega, Walt Disney, pour ne citer qu’eux, se reconnaissent ins-
tantanément, sans qu’il soit nécessaire de lire le logo.
Cependant, un glissement de sens fait désigner comme logotype la représentation
graphique qui l’accompagne la plupart du temps : emblème, insigne, sigle. Quoi qu’il
en soit, logo et graphique associé sont des signes utilisés sur divers supports de com-
munication avec un aspect invariable afin de s’imposer aux esprits. Ils ont pour but de
transmettre l’image que l’entreprise veut donner d’elle-même. Ainsi, lorsque l’entre-
prise change de stratégie, ou veut donner à croire qu’elle s’est modernisée, elle
modifie son logo et l’accorde aux codes graphiques du moment.
Des graphistes de renom ont énoncés des règles pour produire un logotype attei-
gnant l’objectif qu’il vise. Celui qui est proposé dans le présent didacticiel n’a obéi
qu’à l’inspiration du moment, sans autre impératif que de plaire aux commanditaires.

Figure 4–1
Logotype de Scideralle 
réalisé avec Sketch
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Très logiquement, la réalisation du logotype s’effectuera en trois étapes, une étape pour
chaque élément discerné.

Première étape : dessiner le goéland

Ouvrir la session de travail
Avant de commencer à dessiner, quels que soient la méthode ou l’outil, il faut choisir un
support de dimensions appropriées. Conventionnellement, en informatique, le support est
appelé page. Les logiciels de dessin, tout comme XaraLX, en proposent un certain nombre,
de dimensions et de contenus prédéfinis : ce sont les modèles de pages (templates).

Figure 4–2
Modèles (templates) de pages
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On y accède généralement par le menu Fichier>Nouveau. Il suffit alors de choisir celui qui
convient le mieux parmi ceux proposés, en fonction des dimensions et de l’orientation
voulues, mais aussi de la palette de couleurs incluse, dont le nom figure parfois après le
format : 800x600_Deeptone, 800x600Pastel ou encore 36_Named_Colours (voir figure 4-2).

Par défaut, si aucun choix n’est précisé à l’ouverture de la session de travail, la page affi-
chée est celle qui a été sélectionnée lors du paramétrage de XaraLX par le menu
Outils>Options>Page. Des modèles de pages, avec des palettes particulières, dont une
palette CMJN, sont téléchargeables à l’adresse suivante :

Ils doivent être installés dans le répertoire /home/[Votre_nom]/.local/share/xaralx/
Templates.

Dans cet exercice, les copies d’écran et les dimensions se réfèrent à une page de 800 × 600
avec palette CMJN.

Dessiner avec l’outil Crayon
L’outil Crayon (Pen) est destiné au tracé des lignes de Bézier, soit sous forme de segments
rectilignes que l’on courbe par la suite avec l’outil Éditeur de forme (Shape Editor), soit sous
forme de segments courbes plus difficiles à contrôler. Par facilité, autant que par effi-
cience, nous optons pour la première méthode. Le goéland est alors dessiné en deux
temps :
1 mise en place des points d’ancrage limitant les segments rectilignes ;
2 courbure des segments.

Le mode opératoire détaillé ci-après est illustré par la figure 4-3.

B http://www.xaraxone.com/html/templates.html
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� Sélectionner l’outil Crayon et poser les points d’ancrage a, b, c, ..., k et l. Lors du dessin, le
pointeur a la forme d’une croix à laquelle est accolée une spline ; lorsque le contour est
fermé en revenant sur le point a, le pointeur affiche un signe + à côté de la croix.

� Quand le contour est fermé, la forme se remplit de noir par défaut. L’icône d’état des
couleurs A indique pour l’objet sélectionné un contour noir et une surface remplie
d’un aplat noir. Cliquer sur l’icône de suppression de couleur C pour vider la surface et
ne conserver que le contour.

� Par défaut, la largeur du contour est de 0,5 point. La fixer à 1,5 points dans le champ
approprié.

� Activer l’outil Éditeur de forme et cintrer les segments pour que la silhouette du goéland
ressemble à celle de l’image. Pour cela, approcher le pointeur du milieu du segment ab,
par exemple. Quand il prend la forme d’une flèche triangulaire, appuyer sur le bouton
gauche de la souris et, tout en maintenant ce bouton enfoncé, déplacer la souris dans la
sens voulu de la courbure. Procéder de la même manière pour tous les segments dési-
gnés par la flèche triangulaire.

ASTUCE   Les dimensions du goéland

Chacun pourra évidemment dimensionner son dessin comme il lui plaît. Toutefois, il
sera fait mention par la suite de longueurs et de largeurs correspondant aux élé-
ments du dessin d’origine. Afin d’en conserver l’aspect et les proportions, il convient
que chaque élément de la composition conserve sa taille initiale. Ainsi, les extrémités
des ailes du goéland définissent la diagonale d’un rectangle de 234 × 146 pixels. Il
serait donc pertinent de tracer tout d’abord ce rectangle qui servira de limites, puis
de l’effacer quand le goéland sera dessiné.
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Colorier le goéland
Cette opération pourrait être réalisée plus tard, au moment de la finalisation du dessin.
Cependant, nous allons apprendre dès à présent à placer et à modifier les couleurs afin de
ne pas avoir à y revenir par la suite.

Le goéland original se résume à une silhouette bleue remplie d’un aplat blanc ; la petite
difficulté vient du bleu choisi, qui n’existe pas dans la palette. Il va donc falloir le com-
poser. La figure 4-4 décrit la marche à suivre pour cela :
� La forme étant sélectionnée, cliquer sur la couleur blanche de la palette. La surface se

remplit alors de blanc et un petit losange noir, situé à gauche de l’échantillon blanc de
la palette, indique que cette couleur est une couleur de remplissage.

� Effectuer un clic droit sur une couleur dont on n’aura pas besoin par la suite, par
exemple la couleur cyan. Cette couleur est appliquée au contour sélectionné et un petit

Figure 4–3
Dessin du goéland
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losange noir, situé à droite de l’échantillon cyan de la palette, indique que cette couleur
est une couleur de contour.

� La silhouette du goéland est donc d’une couleur cyan que l’on voudrait changer. Pour
cela, faire glisser l’échantillon cyan sur l’icône de l’outil Éditeur de couleur B ou double-
cliquer sur le contour cyan de l’icône d’état des couleurs A ;

� Dans l’outil Éditeur de couleur (Colour Editor), choisir Couleur locale de ligne et HSV
modèle couleur.

PIQÛRE DE RAPPEL   Les modèles colorimétriques

Les différents modes colorimétriques dans XaraLX et les logiciels de graphisme en géné-
ral sont expliqués dans le chapitre 1, aparté « Comprendre les modèles de couleur ».

Figure 4–4
Mise en couleur du goéland
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� Dans le champ de saisie qui contient le codage hexadécimal de la couleur cyan,
#00FFBF, saisir à la place la valeur #5485DC. Fermer l’outil Éditeur de couleur.

� La silhouette du goéland est devenue bleue suite à la modification apportée à la valeur
de la couleur cyan. L’icône de l’état des couleurs a changé en conséquence.

Chacun choisira la méthode d’attribution des couleurs qui lui conviendra le mieux. Il
semble toutefois qu’un clic gauche sur une couleur de la palette pour remplir une surface
et qu’un clic droit pour colorier un contour soit la méthode la plus répandue : c’est celle
utilisée dans CorelDraw, OpenDraw et SK1, par exemple.

ASTUCE   Une autre façon d’attribuer les couleurs

Le glisser-déposer (drag and drop) est couramment proposé par XaraLX. Nous venons
de voir que pour éditer une couleur, il suffit de faire glisser un échantillon de celle-ci
sur l’icône de l’éditeur. Si l’on fait glisser la couleur sur le dessin, le curseur prend la
forme d’une flèche liée, à sa gauche, à un rectangle de même couleur que celle qui
est transportée, et à sa droite, à une flèche courbe �. Lorsque la couleur peut être
déposée sur une surface pour la remplir, la flèche courbe se transforme en carré blanc
� ; lorsque la couleur peut être affectée à un contour, la flèche courbe se transforme
en une ligne verticale �.

Figure 4–5 Curseur d’attribution des couleurs



X
ar

a 
X

tr
em

e 
po

ur
 L

in
ux

82

C
ha

pi
tr

e 
4 

– 
À

 v
os

 so
ur

is
! P

re
m

iè
re

 p
ar

ti
e

Deuxième étape : composer le ciel bicolore
Les deux couleurs du ciel sont des aplats ; nous en déduisons qu’il y a deux surfaces distinctes,
chacune étant remplie avec une couleur différente. Cela suppose d’opérer en deux temps.

Dessiner le fond bleu pâle
Il s’agit d’un simple rectangle qui, du fait de la chronologie de conception, va se trouver
au-dessus du goéland ; en effet, en dessin vectoriel, les objets s’empilent les uns sur les
autres selon l’ordre de leur création. Il va donc falloir le faire descendre dans la pile sous le
goéland. Cette opération s’appelle la disposition verticale. Il s’ensuit le processus décrit
par la figure 4-6.

Figure 4–6
Dessiner le fond bleu pâle
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� Activer l’outil Rectangle et dessiner un rectangle de 170 × 305 pixels qui recouvre le
goéland. Donner au contour une largeur de 2 points.

� Attribuer à la surface la couleur de remplissage #F3F4FE et au contour la couleur
#5485DC.

� Le rectangle étant toujours sélectionné, sélectionner le menu Disposition>Mettre der-
rière (Arrange>Put to Back).

� Le rectangle descend au bas de la pile et le goéland se trouve au sommet.

Dessiner le fond azur
Nous remarquons que cette zone est d’une largeur rigoureusement identique à celle du
fond bleu pâle qui vient d’être mis en place. La façon la plus simple d’obtenir des élé-
ments de forme et dimensions identiques est de les réaliser par clonage ; par la suite, seul
sera modifié ce qui doit l’être, le reste étant inchangé. C’est ce que nous allons faire (voir
figure 4-7).
� Le rectangle bleu pâle étant sélectionné, le cloner grâce au raccourci clavier Ctrl+K.

Rien ne semble avoir changé mais en réalité, un autre rectangle, identique au premier,
le recouvre exactement. C’est d’ailleurs lui qui est sélectionné.

� Déplacer verticalement le segment AB du clone pour obtenir un rectangle de
170 × 153 pixels environ.

� Le point A doit se trouver à l’intérieur d’une aile du goéland, et le le point B à l’inté-
rieur de l’autre aile. Les points A et B ne sont donc plus alignés, alors qu’ils le sont par
construction : il faut pouvoir les déplacer indépendamment, ce qui n’est possible que
s’ils ne sont pas géométriquement liés à un rectangle. Nous allons donc « casser » la
structure rectangulaire par le menu Disposition>Convertir en Formes Éditables
(Arrange>Convert to Editable Shapes).

� Activer l’outil Éditeur de forme et déplacer le point B comme sur la figure.
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� Approcher le pointeur du milieu du segment AB et cliquer sur le segment quand le
pointeur prend la forme d’une flèche triangulaire, un point C est alors ajouté. Dépla-
cer le point C comme illustré sur la figure (le pointeur prend alors la même forme que
celle présentée en A et B).

� Attribuer à la surface une couleur de remplissage azuréenne, #43A8FE.
� Faire reculer le fond azur d’un niveau dans l’empilage pour le disposer sous le goéland,

mais au-dessus du fond bleu pâle. Pour cela, sélectionner le menu Disposition>Déplacer
vers l’arrière (Arrange>Move Backwards).

	 La partie dessin du sujet est terminée.

Troisième étape : insérer le texte
La fonction Texte est très complète dans Xara Xtreme pour Windows, mais elle l’est
moins dans XaraLX, comme nous l’avons déjà signalé. Cependant, le texte se limite ici à
un mot ; les fonctionnalités disponibles sont donc largement suffisantes et ne sont

Figure 4–7
Dessiner le fond azur
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d’ailleurs pas toutes mises à contribution. Le déroulement des opérations pour la mise en
place et la modification du logo « Scideralle » est le suivant (voir figure 4-8).
� Activer l’outil Texte dans la palette.
� Dans la barre d’options, choisir la police de caractères, ici Signature, et régler le corps

du texte à 110 points.

� Placer le curseur de texte (segment vertical rouge), dont la taille est égale au corps du
caractère à l’endroit où débute l’écriture, et écrire « Scideralle ».

� Désactiver le mode texte en choisissant l’outil Sélecteur, décocher l’icône cadenas (Lock
aspect ratio) si besoin, fixer la hauteur de la sélection à 110 % et l’inclinaison à 5°, puis
valider par Entrée. Le mot se déforme mais garde ses caractéristiques de texte, toujours
éditables par l’outil Texte.

� Le mot est actuellement écrit en noir. Nous voulons qu’il possède les mêmes attributs
de couleurs que le goéland. Pour cela, sélectionner le goéland, et le copier dans le

LES MOTS POUR LE DIRE   La fonte de la police

Les termes fonte et police sont indifféremment employés, alors qu’il conviendrait de
faire la distinction entre fonte de caractères et police d’écriture. Une police d’écriture
est un ensemble de glyphes (représentation graphique) constituant la totalité des
signes d’écriture d’une même famille déclinée en différents corps (dimensions),
graisse (épaisseur) et genre (droit, italique). Une fonte est un ensemble de caractères
d’un même corps, d’une même graisse et d’un même genre issu d’une police donnée.
À l’origine, les caractères mobiles d’imprimerie étaient constitués d’un mélange de
plomb et d’antimoine fondu dans des moules, ce qui permettait d’en réaliser un
grand nombre avec toujours la même apparence. Le nom « fonte de caractères »
vient de ce procédé de fabrication. Le terme police se réfère, au temps du caractère
en plomb, au bordereau de commande ou de livraison, ou encore au catalogue défi-
nissant l’ensemble des signes d’une fonte particulière.
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Presse-papiers via le raccourci clavier Ctrl+C. Sélectionner ensuite le texte et coller les
attributs du goéland par Ctrl+Maj+A. Le texte devient blanc avec un contour bleu de
même épaisseur que la silhouette du goéland.

� Régler le contour du texte à 2,5 points.
� Pour remplacer le point sur le « i » du mot « Scideralle », nous allons dessiner une

étoile à cinq branches grâce à l’outil Forme Express.
	 Dans la barre d’options, cocher de gauche à droite : Radius creation, Create polygons et

Starred shapes. Régler le nombre de côtés (Number of sides) à 5.

 Dessiner l’étoile sur le « i », la faire pivoter, l’agrandir et l’incliner si nécessaire de sorte

qu’elle recouvre le point.
� Affecter à l’étoile les mêmes attributs de couleurs que le fond azur au-dessus du goé-

land, puis rendre transparent le contour en effectuant un clic droit sur l’icône C de
suppression des couleurs. L’icône A de l’état des couleurs indique une surface remplie
et un contour vide.

Le travail est terminé. N’oublions pas de le sauvegarder, en nommant le fichier Logotype,
par exemple. Si aucune indication de format n’est spécifiée, le fichier portera l’extension
.xar et sera dans le format spécifique de XaraLX, ou Xara Xtreme pour Windows : les
fichiers produits par les deux logiciels sont lisibles sur les deux plates-formes (à numéro
de version équivalent ou inférieur, bien sûr).
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Figure 4–8
Insérer le texte
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Résumé d’étape
Avant de poursuivre dans la pratique de XaraLX, résumons rapidement ce que nous
venons d’apprendre à faire :
• obtenir des segments courbes de Bézier à partir de segments rectilignes ;
• affecter des couleurs à une surface et à un contour ;
• supprimer et éditer une couleur ;
• disposer verticalement des éléments vectoriels ;
• cloner un élément ;
• insérer du texte et modifier son aspect ;
• copier les attributs d’un élément sur un autre ;
• utiliser une forme expresse prédéfinie.

Un tract (... car il y a affinités !)
Aujourd’hui, plus personne n’appelle tract ce que l’anglomanie ambiante impose de
nommer flyer : ce n’est pas une raison pour faire comme tout le monde. Un tract est donc
un document papier distribué aux gens dans la rue, glissé dans les boîtes aux lettres ou
déposé dans des lieux fréquentés pour annoncer et promouvoir un événement quel-
conque. Il se compose généralement d’une image et d’un texte d’accompagnement.

Nous allons nous concentrer sur l’image, qui va être construite par récupération et multi-
plication du goéland de l’exercice précédent : il y a donc bien affinité entre les deux.




